Automatische updates en WordPress 5.5

matthias, 10 september 2020

Onder #NoMoreWordStress verstaan wij onder andere het automatisch updaten van de plugins op jouw site. Met de komst van WordPress 5.5 en de daarin ingebouwde automatische plug-in- én thema-updates hebben we deze feature opnieuw onder de loep genomen.

Zijn de automatische updates van Savvii nu achterhaald?

Nee, onze automatische updatingtool heeft drie unieke eigenschappen die de ingebouwde update-feature van WordPress 5.5 niet heeft:

  • Wij maken automatisch een back-up vóór het updaten van de plug-ins op je site zodat je altijd terug kan vallen op een eerdere versie van je site.
  • Wij doen een check na het updaten van de plug-ins op je site om te controleren of je site door de update niet down is gegaan. Als dit wel het geval is ontvangen wij hier notificatie van, draaien we de update voor je terug en stellen je hiervan op de hoogte.
  • Wij houden logs bij van het automatische updateproces zodat we bij problemen precies kunnen zien welke updates gedraaid hebben en van/naar welke versie er is geüpdatet.

Een belangrijke kanttekening bij de nieuwe update-functionaliteit in WordPress 5.5 is dat ontwikkelaars zelf bepalen of de feature op hun plug-in geactiveerd kan worden. Grote kans dus dat niet alle plug-ins vanuit WordPress zelf zomaar automatisch geüpdatet kunnen worden. Onze eigen update-functionaliteit heeft hier geen last van. Als je dus zeker wilt zijn dat updates altijd hun doorloop vinden, kun je het beste gebruik blijven maken van onze  eigen automatische update-feature.

Dus ik hoef geen gebruik te maken van de WordPress plugin update feature?

Dat hangt ervan af. Sommige premium plug-ins kunnen wij niet automatisch voor je updaten omdat deze plug-ins zich niet in de WordPress plug-in database bevinden of authenticatieproblemen geven. Je kan hier een lijst vinden met plug-ins die wij momenteel niet ondersteunen. Als je gebruik maakt van een van de genoemde plug-ins én de ontwikkelaar de update-feature van WordPress ondersteunt, kan je hiervan gebruik maken om deze plug-in up-to-date te houden.

Als je gebruik wilt maken van de mogelijkheid om thema’s automatisch te laten updaten is de ingebouwde updater van WordPress ook interessant omdat wij momenteel nog geen ondersteuning bieden voor het automatisch updaten van thema’s. De automatische update-feature van WordPress 5.5. voor het updaten van thema’s sluit de automatische plug-in updates van Savvii niet uit, je kan deze functionaliteiten naast elkaar gebruiken.

Is het verstandig om thema’s automatisch te laten updaten door WordPress?

Hoewel thema’s soms veiligheidslekken bevatten en belangrijk zijn om up-to-date te houden geef je met het automatisch updaten van je thema een stukje controle weg. Een thema bepaalt het gezicht van je site en als een thema-ontwikkelaar een uitglijder maakt en je hebt automatische thema updates ingeschakeld kan dat ervoor zorgen dat je site er plots anders uitziet. Je zal hierin voor je site een eigen afweging moeten maken of je thema’s automatisch door WordPress wilt laten updaten of niet. Wat kan helpen in je keuze is om te controleren of er ooit een veiligheidslek in jouw gekozen thema is geweest. Als dit het geval is, kan je natuurlijk voor een ander thema kiezen of nalopen hoe snel het lek door de thema-ontwikkelaar was gedicht en alsnog besluiten om er gebruik van te maken.

Mocht je meer te weten willen komen over ons automatische update-proces, neem dan gerust contact met ons op of bekijk onze supportpagina.

Reageer